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Opening images (Bio-Formats) 
1. Drag an image to the Fiji tool bar or select File>Open from the top menu 

 
2. If the image you are opening is a standard format e.g. TIFF, JPG, PNG it should open 

immediately.  If the file type is more obscure you will see the Bio-Formats Import 
Options window which allows you to set how the image should be opened: 
 
Stack Viewing 
Determines the window type used to display the image, choose Hyperstack. 
 
Metadata Viewing 
Opens the standard metadata and/or OME-XML metadata, the latter can be useful 
when opening OME-Tiffs i.e. Micro-Manager files & will give details of how the 
image was caotured. 
 
Memory Management 

1. For datasets too large to be loaded into memory, Virtual Stack is a good option as it 
only reads the image plane you are viewing into memory at a time. 
 

2. Specify Range For Each Series opens only the specified range of image planes as 
selected by the user.  A second dialog will open once the dimensions of the dataset 
have been analysed by Bio-Formats.  This allows you to select how much of the data 
you want to open. 

 
3. Crop on import allows the X x Y dimensions of the image to be cropped to save on 

memory.  In the dialog in the first two boxes you should input the top left corner 
pixel number of the rectangle you want to crop.  The second two boxes tell’s bio-
formats how big the cropped region should be. 
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Color Options 
1. Color mode dictates how the channel colours are handled in the images.  The most 

common option is “Composite”.  The channels will be merged & open as a single 
plane, coloured according to the image metadata. 
 

2. Colorized will show a plane for each channel in a single window with a scroll bar ath 
the bottom, so you will only be able to see one channel at a time. 

 
3. If Autoscale is selected the image intensity display range will map to the min & max 

data values in the image rather than the bit depth limits of the file format (0-255, 0-
4095 etc).  Useful for 12-16bit images as often the data is low intensity and is often 
only several thousand counts, mapping to the full range would make the image hard 
to see. 

Adjusting the image window size and magnification 
1. The size of the image window on the screen will depend on the physical pixel 

dimensions of the image itself and FIJI will try to optimise it. 
 

2. You can increase/decrease the zoom and size of the image by selecting the 
Magnifying Glass icon.  Left click to magnify, Ctrl-left click to de-magnify (% size 
shown next to the image title). 

3. When you magnify you’ll see two purple rectangles in the top left 
corner of the image.  The outer rectangle represents the whole image 
& the inner rectangle is the part of the image you can see on the 
screen.  If you want to see more of the image you can go to the bottom 
right corner of the image and drag it out.  Alternatively, if you don’t 
want to increase the amount of screen the image is occupying you can 
select the hand tool then left click and drag to make another part of the image 
visible. 
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Selecting a channel and changing colours 
1. Most images will open with the channels merged & in Composite Image mode.  

Typically there will be a horizontal scroll bar along the bottom of the image labelled 
“C” for Channel.  Notice when you move this the image doesn’t change apart from 
the colour of the text at the top & the bounding box around the image.  This is 
selecting a particular channel of the image for further manipulation e.g. to adjust the 
brightness of the selected channel only. 
 

2. To physically toggle a channel off go to Image>Color>Channels Tool 
Then uncheck the channels as required. 
 

3. If you want to change the colour of a particular channel, select the 
channel with the “C” scroll bar along the bottom then select 
Image>Lookup Tables & choose from the list.  

 

Brightness and Contrast 

1. Select the channel first as described above then select 
Image>Adjust>Brightness/Contrast 
 

2. Where you see the histogram the two values on the x axis are the 
minimum and maximum displayed values.  In simple terms moving 
the maximum scroll bar to the left will make the image brighter & to 
the left darker.  Moving the minimum to the right will make the 
lower intensity pixels (background) appear to have a higher value or 
lower if moved to the left.    
 

3. For an 8-bit image pixel intensity values are in the range 0-255 
(0=black, 255=white).  When you adjust the min and max you should 
consider these new values as if they were 0 & 255.  For example if 
the max is set to 208 any pixel with a value =>208 will appear to 
have an intensity equal to 255 on the display.  Likewise for the minimum, if it was set 
to 10 then any value <=10 will appear to have an intensity equal to 0.   
 

4. Its important to note that this just changes the image display but does not change 
the underlying pixel values when you view a histogram or make intensity 
measurements.  However, if you press the Apply button this will then set the 
underlying pixel values to the current display range & will affect intensity 
measurements but it will only do this for 8-bit images. 

 
5. Pressing Auto automatically optimises brightness & contrast based on the image’s 

histogram.  It makes a proportion of the pixels saturated.  FIJI by default will run the 
Auto brightness/contrast function when you open an image as well. 
 

6. Press Reset to set the display range e.g 0=208 to the full pixel value range e.g. for an 
8bit image 0-255. 
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7. How you set the brightness & contrast is important 
when you want to visually compare the intensity of 
several images captured with the same exposure 
time.  You should either set them all to the full 
pixel value range by pressing Reset or use the Set 
button to manually set the display range.  You can 
then propagate these values to the other open 
images. 

 
8. The Unsigned 16-bit range drop down menu allows you to scale the range of grey 

levels for 16bit images.  E.g. if your 16bit image has a maximum of 3000 and the 
display range is set to the pixel value range 0-65535 the image will be very dark, but 
would be easier to see if you set it to the 12bit 0-4095 range for example. 

Working with multi-dimensional images 
1. When you open an image that includes multiple dimensions e.g. Z, Multi-point & 

Time you can only look at one image frame at once.  There should be horizontal 
scroll bars at the bottom of the image to allow you to move through each dimension 
e.g. C, Z, T 

 
 
 
 
 
 
 
 
 
 
 
 
 

2. Many of the function’s relating to image stacks are found in Image>Stacks 
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Image properties, setting scale & scale bars 
 

1. Select Image>Show info & you will see the metadata of the image.  If you need to 
find out a particular detail about the image or how it was taken this is where to do it. 
 

2. Images with no scale set will only list dimensions in pixels at the top of the image.  If 
a scale is set you will also see the dimensions in µm. 
 

3. If you need to set or adjust the scale go to 
Analyse>Set Scale 
 

4. If a scale is set you can see it at the bottom of the 
window.  To adjust the scale set the Distance In 
Pixels to 1.  The known Distance is the number of 
µm 1 pixel represents.  You need to know this 
figure in order to set the scale correctly. 

 
5. Once the scale is set you can add a scale bar to the 

image through Analyse>Tools>Scale Bar 
 

6. You can change various aspects of the scale bars 
appearance most of which is self-explanatory.  If Overlay 
is selected then the scale bar is added as an overlay.  This 
is a non-permanent addition to the image which doesn’t 
affect underlying pixel values.  You can hide or show an 
overlay at any time using Image>Overlay>Show/Hide 
Overlay.  It will only be accessible when you open the 
image in FIJI.  If Overlay is not ticked then the scale bar is 
“stamped” onto the image and is permanent and cannot 
be removed.  It also becomes part of the pixel data and 
will affect any intensity based measurements.   
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Selections & ROIs (ROI Manager) 
1. A Selection is essentially an ROI.  They are used to isolate a 

part of the image e.g. if you want to crop the image or if 
you want to measure only within a defined area.  You can 
use any of the selection tools to draw a selection on the 
image. 
 

2. If you want to add multiple selections to the image & recall 
them at any point, use the ROI Manager 
(Analyse>Tools>ROI Manager). 
 

3. Draw a selection then press Add to store it, a row will be 
added to the ROI Manager table.  You can add multiple 
selections to the image in this way.  Clicking on a row will 
make it active and show it on the image. 
 

4. Change the colour of selections using Edit>Options>Colors 
 
 

Image Wide & Selection Based Measurements 
1. Select Analyse>Set Measurements, here you can decide 

what measurements you want to make 
 

2. Limit to threshold applies if a threshold has been applied 
to the image, see sections below 

 
3. Add to overlay creates a removable layer on the image 

which will highlight what has been measured, this can be 
toggled off/on via Image>Overlay>Show/Hide Overlay 
 

4. Redirect To enables selection of any open image and the 
measurements will be done on the image selected 
 

5. To calculate these measurements select Analyse>Measure 
 

6. If you draw a selection before pressing measure only the pixels within the selection 
will be measured 
 

7. A table of the results will open, save it using File>Save As 
 

8. To summarize the results and get the mean, SD, minimum & maximum of the values 
in each column select Results>Summarize 
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 Identification Of Objects & Measurements (Thresholding) 
1. Setting a threshold is a means to segment images into features 

of interest and background.  It is intensity based & involves 
isolating intensities of interest using the image histogram. 
 

2. Select Image>Adjust>Threshold.  An automatic threshold will be 
calculated and any pixels included in the threshold will be 
coloured red.  Those pixels fall within the red box now on the 
histogram in the threshold window. 
 

3. You can expand/reduce the limits of the threshold to 
include more or less intense pixels by moving the 
horizontal scroll bars.  Press Auto to go back to the 
auto calculated threshold 
 

4. Reset will remove the threshold altogether 
 

5. Apply will binarize the image i.e. all pixels in the 
threshold become black, a value of 0 & all pixels in the 
background become white, a value of 255.  Using 
Apply isn’t necessary, just close the threshold window 
and the threshold will still be visible on the image 
 

6. Set the measurements you want to calculate as 
described earlier then select Analyse>Analyze 
Particles. 
 

7. The size box is a size filter, by default any object size 
is accepted so long as it falls within the threshold.  
Note the size is the area in pixels. 
 

8. Circularity filters how close to a perfect circle the 
objects are, where 1 is a perfect circle.  This is 
difficult to set without having a preview of how this 
affects the objects included in the threshold. 
 

9. The Show drop down determines how the identified objects will be displayed, 
Outlines is useful as it creates a new image with no data other than the outline of 
each object a number to identify it. 
 

10. Display Results will show the results table and associated values from all objects 
 

11. Exclude On Edges & Include Holes will exclude any objects touching the image 
boundary & will include any objects where the threshold encompasses the object 
but an area internally is not within the threshold respectively 
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12. Selecting Add To Manager will add all the identified objects as separate rows in the 
ROI Manager.  This allows selection of any of the objects for further individual or 
batch processing   
 

13. You could delete all objects not meeting your criteria by holding ctrl click to select 
them then press Delete.  Then measure the remaining again by selecting Show All & 
press Measure from the ROI Manager 

 

When auto threshold doesn’t accurately detect objects 
Filters 
Filtering is a method to modify or enhance an image by altering the values of pixels within a 
local pixel neighbourhood in a structured way.  The filter applies what is known as a 
structuring element or kernel to each pixel in the image.  In the image below the kernel, in 
green is 3x3 in size but they can vary.  How the distribution of values vary in the kernel & 
the mathematical operations calculated between the image and kernel pixels determine the 
filter type.  As an example a mean filter will replace the image pixel with the mean of its 
surrounding neighbour pixels.  
 
Applying filters can help to make thresholding an image & thus detection of objects of 
interest more accurate. 

 
 
 
 
 
 
 
 
 

 
 

1. Filters are found under Process>Filters.  Some common filters and 
examples of when to use them are described below: 
 

• Median-reduces noise in the image by replacing each pixel with 
the median of the neighbouring pixel values.  The radius gives 
the radius of the kernel (r=2 equates to a 3x3 kernel) 
 

• Mean-Smooths the image by replacing each pixel with the neighbourhood mean 
 

• Min & Max-Either replaces all pixels in the neighbourhood with the lowest value 
pixel or the highest respectively.  The effect of the minimum filter is make an 
object thicker, likewise the maximum filter will make an object thinner. 

 
 
 
 



 10 

Binary Operations 
A binary image is simply one made up of only black & white pixels (0 or 255 for 8-bit 
images).  It is common in image processing to create a binary or mask copy of your image, 
often after an initial threshold has been applied.  This mask can then be further processed 
as described below to more accurately segment objects.  This mask can then be applied to 
your image to outline objects of interest thus allowing measurements to be taken. 
 

1. Select Process>Binary>Make Binary.  The histogram of the image or selection is 
analysed and the binary values are automatically calculated, the same calculation as 
is carried out when using auto threshold. 
 

2. By default the foreground will be black and the background white, you can flip this 
so that foreground is white & the background black as is more common in 
fluorescence by selecting Edit>Invert 
 

3. If a manual threshold has been applied to the image (Image>Adjust>Threshold) then 
this will determine what becomes foreground & background in the binary image 
 

4.  Now you have a binary image you have access to the binary operations found in the 
Process>Binary menu: 
 
Fill Holes 
Imagine an object whereby an area of background (white) is completely 
enclosed by foreground (black).  I want to measure the area of the black 
circle including the internal white hole.  If I ran a threshold on this, I 
would be able to threshold either the black or white area but not the 
black area including the white area.  This is where Fill Holes is useful 
Process>Binary>Fill Holes 
Note that you can also utilise fill holes through the Analyze Particles 
menu 
 
Watershed 
A way to automatically cut or separate touching objects.  A good 
example for using this would be a field of clumped nuclei where you 
wanted to count them as shown right.  When the Watershed is 
applied the joined nuclei are separated & would thus be counted as 
separate objects by the Analyse Particles command.  See below for 
the workflow of how you would do this: 
 

• Duplicate your original image Image>Duplicate 

• Process>Binary>Make Binary 

• Process>Binary>Watershed 

• Analyze>Analyze Particles 

• Ensure Add to Manager is selected  

• The ROI Manager will then populate with the objects, press Measure 
(assumes you have set the required measurements, Analyze>Set 
Measurements) 


	Opening images (Bio-Formats)
	Adjusting the image window size and magnification
	Selecting a channel and changing colours
	Working with multi-dimensional images
	Image properties, setting scale & scale bars
	Selections & ROIs (ROI Manager)
	Image Wide & Selection Based Measurements
	Identification Of Objects & Measurements (Thresholding)
	When auto threshold doesn’t accurately detect objects

